The outage that was impacting several services is now resolved. All services should now be functioning normally. If you continue to experience any issues, please call the ITS Helpdesk at (630) 844-5790.
Posted Jun 22, 2026 - 10:18 CDT
Investigating
We are currently experiencing an outage impacting several services.
Affected services include Zendesk, Zoom, Microsoft Teams, Monday.com, and potentially others. You may be unable to access these services, or experience slower load times, intermittent errors, or limited functionality.
We will share more details as they are confirmed. We apologize for the inconvenience and will provide updates as more information becomes available. If you need assistance, please call the ITS Helpdesk at (630) 844-5790. Thank you for your patience.
Posted Jun 22, 2026 - 09:25 CDT
This incident affected: Collaboration and Communication (Microsoft Teams, Zoom Meetings, Zoom Live Transcription, Zoom Closed Captioning, Zoom Archiving, monday.com Dashboards, monday.com Login / SSO) and Applications and Systems (Zendesk).