Colleague UI Incomplete Loading and Slowness

Incident Report for AU ITS Status Page

Resolved

Colleague UI has been restored and is expected to be fully operational. If you continue to experience issues logging in or unusual slowness, please contact the ITS Helpdesk at itshelp@aurora.edu so we can investigate further.
Posted Mar 30, 2026 - 10:26 CDT

Investigating

Some users are experiencing issues with Colleague UI, including incomplete loading and slow performance. A priority support ticket has been opened with Ellucian. We will provide an update as soon as more information is available.

Self-Service is fully operational and unaffected.
Posted Mar 30, 2026 - 09:30 CDT
This incident affected: Colleague (Colleague SaaS Production).