Colleague UI Incomplete Loading and Slowness

Incident Report for AU ITS Status Page

Update

We are continuing to work with Ellucian on an escalated support ticket to resolve incomplete loading and slow performance issues in Colleague UI. We will provide an update as soon as more information is available.
Posted Mar 31, 2026 - 17:13 CDT

Investigating

Some users are experiencing issues with Colleague UI, including incomplete loading and slow performance. An escalated support ticket is open with Ellucian. We will provide an update as soon as more information is available.
Posted Mar 31, 2026 - 10:16 CDT
This incident affects: Colleague (Colleague SaaS Production).