Colleague UI Incomplete Loading and Slowness (Recurring)

Incident Report for AU ITS Status Page

Resolved

Earlier today, some users encountered slow page loading and difficulty logging into Colleague UI. The issue is now resolved and full service is restored.
Posted Mar 30, 2026 - 17:09 CDT

Investigating

Some users are experiencing performance issues with Colleague UI again, including slow loading and login difficulties. This appears to be a recurrence of the earlier incident today. Ellucian is actively investigating and we will provide updates as more information becomes available.

Self-Service remains fully operational and unaffected.
Posted Mar 30, 2026 - 11:00 CDT
This incident affected: Colleague (Colleague SaaS Production).