Printing Services Disruption

Incident Report for AU ITS Status Page

Resolved

Printing on campus has been restored and is now operating normally. If you are still experiencing issues, please try resubmitting your print job or restarting your device. If problems persist, please contact the ITS Helpdesk at itshelp@aurora.edu.

Thank you for your patience while we worked with support to resolve this.
Posted May 08, 2026 - 17:09 CDT

Investigating

We are currently experiencing an issue with printing on campus. Print jobs may fail to process or appear stuck in the queue. We are aware of the issue and actively investigating with our vendor. We will provide an update as soon as we have more information.

Thank you for your patience.
Posted May 08, 2026 - 15:04 CDT
This incident affected: Applications and Systems (Printing).