Ellucian is reporting that the short-term mitigations were validated and Insights performance is stable now. This will continue being monitored by Ellucian for the rest of the week.
Posted Aug 05, 2026 - 20:11 CDT
Update
Ellucian is continuing to monitor the short-term remediations in place and is working to improve system stability.
Posted Aug 05, 2026 - 15:20 CDT
Identified
Ellucian has identified potential causes of the Insights performance issues and deployed short-term mitigation measures to partially restore stability. Ellucian is monitoring the platform and working on permanent fixes, but users may still experience latency in the meantime.
Posted Aug 05, 2026 - 14:29 CDT
Investigating
Ellucian is currently investigating performance issues affecting the Insights platform. Some users may experience delays running population jobs, ingesting data, and executing Insights-related Data Connect pipeline runs. Insights performance may be slower while Ellucian works to resolve the problem. An update will be shared once more information becomes available.
Posted Aug 05, 2026 - 13:26 CDT
This incident affected: Ellucian Colleague (Insights Production, Insights Test).